summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-11-06 02:10:28 +0000
committerPaul Spooren <mail@aparcar.org>2021-10-07 23:22:18 -1000
commita7f794cd2aa104fdbd4c6e38f9b76373bf9b96e1 (patch)
tree14eaf9504c6314ff27a58613d0aab7d7210adcde /include/target.mk
parent44f694ba1bca1417d24e851c637c284f9f78c06d (diff)
downloadopenwrt-a7f794cd2aa104fdbd4c6e38f9b76373bf9b96e1.tar.gz
build: select procd-seccomp if kernel support is present
Install ld-preload hooks allowing to add seccomp filters for arbitrary services if kernel support for seccomp is present. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index eac2d164c3..03192d3ebe 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -38,6 +38,11 @@ ifeq ($(CONFIG_SMALL_FLASH),)
DEFAULT_PACKAGES+=procd-ujail
endif
+# include seccomp ld-preload hooks if kernel supports it
+ifneq ($(CONFIG_KERNEL_SECCOMP),)
+DEFAULT_PACKAGES+=procd-seccomp
+endif
+
# For the basic set
DEFAULT_PACKAGES.basic:=
# For nas targets