summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-24 12:40:00 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-24 13:15:01 +0100
commitbfdc56d3a2c8d733ccb40f683f2f058a121933cb (patch)
treea79cea77bade35e9d75f778c4ccdfa635bff0736 /include/target.mk
parentcbbd71b6e50f057b2ff5acc05980152005e1cfeb (diff)
downloadopenwrt-bfdc56d3a2c8d733ccb40f683f2f058a121933cb.tar.gz
build: remove mips16 feature flag from target makefiles
It can be implicitly derived from the MIPS32 revision support in the kernel configuration Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 2e0bf4957d..597563d5ec 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -258,6 +258,9 @@ ifeq ($(DUMP),1)
ifneq ($(CONFIG_VIRTIO),)
FEATURES += virtio
endif
+ ifneq ($(CONFIG_CPU_MIPS32_R2),)
+ FEATURES += mips16
+ endif
FEATURES += $(foreach v,6 7,$(if $(CONFIG_CPU_V$(v)),arm_v$(v)))
# remove duplicates