summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2018-06-19 08:44:54 +0200
committerJohn Crispin <john@phrozen.org>2018-06-20 15:36:02 +0200
commitc6e02b49f65cb4eff624a0831d3db265b3fadd2a (patch)
treef5a25a376b633c5ca0fadd07eb5879646da3b323 /include/target.mk
parent4bb2532ec1d4f30ad44037331130daffa687eb3d (diff)
downloadopenwrt-c6e02b49f65cb4eff624a0831d3db265b3fadd2a.tar.gz
octeon: Add and set CPU type Octeon+ as default
The lowest CPU type used by supported Octeon platform is Octeon+ (EdgeRouter Lite) while EdgeRouter Pro/ER-8 uses Octeon II which is backwards compatible with Octeon+. Sources: https://community.ubnt.com/t5/EdgeRouter/EdgeRouter-Pro-CPU/td-p/654599 https://www.cavium.com/octeon-II-CN68XX.html "OCTEON II family is fully software compatible with the widely-adopted OCTEON Plus family" Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index a97cda2c3a..6afbd75839 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -176,6 +176,7 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_24kc = -mips32r2 -mtune=24kc
CPU_CFLAGS_74kc = -mips32r2 -mtune=74kc
CPU_CFLAGS_octeon = -march=octeon -mabi=64
+ CPU_CFLAGS_octeonplus = -march=octeon+ -mabi=64
endif
ifeq ($(ARCH),i386)
CPU_TYPE ?= pentium