summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2018-01-16 15:46:44 -0700
committerJohn Crispin <john@phrozen.org>2018-02-13 13:02:03 +0100
commitca32373c951c651f4fe5d8f99ddeb8d4f20bbe3e (patch)
tree3208c5568011c2f0106ea5eb5b03544936bea420 /include/target.mk
parent4baffa02ce2f3b04be37628f0965b0bade5019cf (diff)
downloadopenwrt-ca32373c951c651f4fe5d8f99ddeb8d4f20bbe3e.tar.gz
target.mk: let profile remove from DEFAULT_PACKAGES
In a profile, specifying -pkg in the list of PACKAGES will suppress it even if it appears in the target's DEFAULT_PACKAGES list. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 8ee197f1c4..b84468997a 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -68,6 +68,8 @@ define Profile
$(eval $(call ProfileDefault))
$(eval $(call Profile/$(1)))
dumpinfo : $(call shexport,Profile/$(1)/Description)
+ DEFAULT_PACKAGES := $(filter-out $(patsubst -%,%,$(filter -%,$(PACKAGES))),$(DEFAULT_PACKAGES))
+ PACKAGES := $(filter-out -%,$(PACKAGES))
DUMPINFO += \
echo "Target-Profile: $(1)"; \
$(if $(PRIORITY), echo "Target-Profile-Priority: $(PRIORITY)"; ) \