summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2020-08-27 11:47:07 -1000
committerDaniel Golle <daniel@makrotopia.org>2020-08-31 11:26:10 +0100
commitcc5bdcd0557b30482aeea6dbeaa2ed40b3a7acdb (patch)
treea31b0c7454a88ae141cb9cbaf235f03c874dcfb9 /include/target.mk
parente79df3516d3e2931a2a2964cadfed0af99acef49 (diff)
downloadopenwrt-cc5bdcd0557b30482aeea6dbeaa2ed40b3a7acdb.tar.gz
build: sort default packages and split by newlines
The line of default packages became very long and it is easier to read one package per line, therefore split it by newlines and sort it alphabetically. Signed-off-by: Paul Spooren <mail@aparcar.org>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk35
1 files changed, 32 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index b0c563a0ef..03550c6ca6 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -13,13 +13,42 @@ __target_inc=1
DEVICE_TYPE?=router
# Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files busybox ca-bundle dropbear fstools libc libgcc logd libustream-wolfssl mtd netifd opkg uci uclient-fetch urandom-seed urngd
+DEFAULT_PACKAGES:=\
+ base-files \
+ busybox \
+ ca-bundle \
+ dropbear \
+ fstools \
+ libc \
+ libgcc \
+ libustream-wolfssl \
+ logd \
+ mtd \
+ netifd \
+ opkg \
+ uci \
+ uclient-fetch \
+ urandom-seed \
+ urngd
# For the basic set
DEFAULT_PACKAGES.basic:=
# For nas targets
-DEFAULT_PACKAGES.nas:=block-mount fdisk lsblk mdadm
+DEFAULT_PACKAGES.nas:=\
+ block-mount \
+ fdisk \
+ lsblk \
+ mdadm
# For router targets
-DEFAULT_PACKAGES.router:=dnsmasq iptables ip6tables ppp ppp-mod-pppoe firewall odhcpd-ipv6only odhcp6c kmod-ipt-offload
+DEFAULT_PACKAGES.router:=\
+ dnsmasq \
+ firewall \
+ ip6tables \
+ iptables \
+ kmod-ipt-offload \
+ odhcp6c \
+ odhcpd-ipv6only \
+ ppp \
+ ppp-mod-pppoe
ifneq ($(DUMP),)
all: dumpinfo