summaryrefslogtreecommitdiff
path: root/include/target.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-10-19 16:55:39 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-10-21 11:56:26 +0100
commitd355b578b7cc95c5b07fcecb217dbac4c05bd49c (patch)
treeb8c593c7a02a0cf74a0c4cd1fb48d1f9ce443a36 /include/target.mk
parent610843f3bc72d2a7c32fbb7c61d0c4416a88d1d9 (diff)
downloadopenwrt-d355b578b7cc95c5b07fcecb217dbac4c05bd49c.tar.gz
target: include selinux-variants if CONFIG_SELINUX is set
Rather than unconditionally adding busybox and procd to the set of default packages, add busybox-selinux and procd-selinux in case CONFIG_SELINUX is set. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index 31ce592c8b..a2e76f8149 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -15,7 +15,6 @@ DEVICE_TYPE?=router
# Default packages - the really basic set
DEFAULT_PACKAGES:=\
base-files \
- busybox \
ca-bundle \
dropbear \
fstools \
@@ -30,6 +29,13 @@ DEFAULT_PACKAGES:=\
uclient-fetch \
urandom-seed \
urngd
+
+ifneq ($(CONFIG_SELINUX),)
+DEFAULT_PACKAGES+=busybox-selinux procd-selinux
+else
+DEFAULT_PACKAGES+=busybox procd
+endif
+
# For the basic set
DEFAULT_PACKAGES.basic:=
# For nas targets