summaryrefslogtreecommitdiff
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2021-02-27 19:12:10 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-02-28 00:09:09 +0000
commitdc5328e7e9d97ea779fa06621ce6da8deaac56c9 (patch)
tree5045851d252aa7688e52b6a6ec295b46aaa6a85a /include/unpack.mk
parentad54e32651c9de5079ca1b6e637edb2ebfe59656 (diff)
downloadopenwrt-dc5328e7e9d97ea779fa06621ce6da8deaac56c9.tar.gz
include: use cpio from staging dir
As we built our own CPIO now, use this version instead of whatever the host may or may not provide. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 6a56b8e742..ebece69978 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -40,7 +40,7 @@ ifeq ($(strip $(UNPACK_CMD)),)
UNPACK_CMD=$(DECOMPRESS_CMD) $(TAR_CMD)
endif
ifeq ($(EXT),cpio)
- UNPACK_CMD=$(DECOMPRESS_CMD) (cd $(1)/..; cpio -i -d)
+ UNPACK_CMD=$(DECOMPRESS_CMD) (cd $(1)/..; $(STAGING_DIR_HOST)/bin/cpio -i -d)
endif
ifeq ($(EXT),zip)
UNPACK_CMD=$(UNZIP_CMD)