summaryrefslogtreecommitdiff
path: root/package/system/gpio-cdev/nu801/Makefile
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2021-07-30 17:59:25 +0200
committerChristian Lamparter <chunkeey@gmail.com>2023-05-14 00:08:35 +0200
commit1d49310fdb5e6febd2e7a60d55deb0adb4364307 (patch)
treef1c9b003fd8dbcf1ca46349b44cf5628567f5b8d /package/system/gpio-cdev/nu801/Makefile
parentcb9ccd644bf986d5c23e40dda92576d36a1d3b1b (diff)
downloadopenwrt-1d49310fdb5e6febd2e7a60d55deb0adb4364307.tar.gz
ath79: add Cisco Meraki MR18
Specifications: SOC: Atheros/Qualcomm QCA9557-AT4A @ 720MHz RAM: 2x Winbond W9751G6KB-25 (128 MiB) FLASH: Hynix H27U1G8F2BTR-BC TSOP48 ONFI NAND (128 MiB) WIFI1: Atheros AR9550 5.0GHz (SoC) WIFI2: Atheros AR9582-AR1A 2.4GHz WIFI2: Atheros AR9582-AR1A 2.4GHz + 5GHz PHYETH: Atheros AR8035-A, 802.3af PoE capable Atheros (1x Gigabit LAN) LED: 1x Power-LED, 1 x RGB Tricolor-LED INPUT: One Reset Button UART: JP1 on PCB (Labeled UART), 3.3v-Level, 115200n8 (VCC, RX, TX, GND - VCC is closest to the boot set jumper under the console pins.) Flashing instructions: Depending on the installed firmware, there are vastly different methods to flash a MR18. These have been documented on: <https://openwrt.org/toh/meraki/mr18> Tip: Use an initramfs from a previous release and then use sysupgrade to get to the later releases. This is because the initramfs can no longer be built by the build-bots due to its size (>8 MiB). Note on that: Upgrades from AR71XX releases are possible, but they will require the force sysupgrade option ( -F ). Please backup your MR18's configuration before starting the update. The reason here is that a lot of development happend since AR71XX got removed, so I do advise to use the ( -n ) option for sysupgrade as well. This will cause the device to drop the old AR71xx configuration and make a new configurations from scratch. Note on LEDs: The LEDs has changed since AR71XX. The white LED is now used during the boot and when upgrading instead of the green tricolor LED. The technical reason is that currently the RGB-LED is brought up later by a userspace daemon. (added warning note about odm-caldata partition. remove initramfs - it's too big to be built by the bots. MerakiNAND -> meraki-header. sort nu801's targets) Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'package/system/gpio-cdev/nu801/Makefile')
-rw-r--r--package/system/gpio-cdev/nu801/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/system/gpio-cdev/nu801/Makefile b/package/system/gpio-cdev/nu801/Makefile
index f91fbbc8ae..67b2a771ec 100644
--- a/package/system/gpio-cdev/nu801/Makefile
+++ b/package/system/gpio-cdev/nu801/Makefile
@@ -20,7 +20,7 @@ define Package/nu801
SECTION:=utils
CATEGORY:=Utilities
SUBMENU:=Userspace GPIO Drivers
- DEPENDS:=@(TARGET_x86||TARGET_bcm53xx)
+ DEPENDS:=@(TARGET_ath79_nand||TARGET_bcm53xx||TARGET_x86)
KCONFIG:=CONFIG_GPIO_CDEV=y
TITLE:=NU801 LED Driver
endef