summaryrefslogtreecommitdiff
path: root/rules.mk
diff options
context:
space:
mode:
authorVincent Wiemann <vincent.wiemann@ironai.com>2020-12-28 16:00:13 +0100
committerChristian Marangi <ansuelsmth@gmail.com>2022-07-24 19:53:43 +0200
commit2555ffb4536e2727465e9a0d426ad3c4f1ef003a (patch)
tree2816b61d2d07234a9c816dfe6fc9a81bf42cb8f1 /rules.mk
parent0f301b0b1d7ca4b5fe290a72f0434525405f5a26 (diff)
downloadopenwrt-2555ffb4536e2727465e9a0d426ad3c4f1ef003a.tar.gz
rules_mk: use gcc versions for external toolchain
When using the OpenWrt toolchain as an external toolchain the build failed due to missing LTO support. By choosing the GCC wrappers of the tools this commit makes sure that the LTO-enabled executables are being used. Signed-off-by: Vincent Wiemann <vincent.wiemann@ironai.com> [ wrap the commit description to 72 char ] Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk13
1 files changed, 3 insertions, 10 deletions
diff --git a/rules.mk b/rules.mk
index 8a4254e638..dd375ff3d5 100644
--- a/rules.mk
+++ b/rules.mk
@@ -243,20 +243,13 @@ HOST_CXXFLAGS:=
HOST_CFLAGS:=-O2 $(HOST_CPPFLAGS)
HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib $(if $(IS_PACKAGE_BUILD),-L$(STAGING_DIR_HOSTPKG)/lib -L$(STAGING_DIR)/host/lib)
-ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
- TARGET_AR:=$(TARGET_CROSS)gcc-ar
- TARGET_RANLIB:=$(TARGET_CROSS)gcc-ranlib
- TARGET_NM:=$(TARGET_CROSS)gcc-nm
-else
- TARGET_AR:=$(TARGET_CROSS)ar
- TARGET_RANLIB:=$(TARGET_CROSS)ranlib
- TARGET_NM:=$(TARGET_CROSS)nm
-endif
-
BUILD_KEY=$(TOPDIR)/key-build
FAKEROOT:=$(STAGING_DIR_HOST)/bin/fakeroot
+TARGET_AR:=$(TARGET_CROSS)gcc-ar
+TARGET_RANLIB:=$(TARGET_CROSS)gcc-ranlib
+TARGET_NM:=$(TARGET_CROSS)gcc-nm
TARGET_CC:=$(TARGET_CROSS)gcc
TARGET_CXX:=$(TARGET_CROSS)g++
KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh