summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-03-23 03:53:52 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-04 06:07:30 +0200
commit87e902fcdcce0e3d1287deb901f934aabf7ec183 (patch)
tree72e8fb21e2c40250fa9c6a78e3e6a20cec59a849 /tools
parentd95d5d2a3a895f5374b56ab349f628578cd4149b (diff)
downloadopenwrt-87e902fcdcce0e3d1287deb901f934aabf7ec183.tar.gz
tools/libtool: bootstrap to local gnulib source
Using the local gnulib source during bootstrap allows for fine-grained control over the macros and source files for use with libtool but part of gnulib instead of libtool, without having to wait for a release or deal with gnulib as a git submodule. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'tools')
-rw-r--r--tools/Makefile2
-rw-r--r--tools/libtool/Makefile18
2 files changed, 17 insertions, 3 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 3bf94827cf..3f12828a8f 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -104,7 +104,7 @@ $(curdir)/gmp/compile := $(curdir)/libtool/compile
$(curdir)/isl/compile := $(curdir)/gmp/compile
$(curdir)/liblzo/compile := $(curdir)/cmake/compile
$(curdir)/libressl/compile := $(curdir)/pkgconf/compile
-$(curdir)/libtool/compile := $(curdir)/automake/compile $(curdir)/missing-macros/compile
+$(curdir)/libtool/compile := $(curdir)/automake/compile $(curdir)/gnulib/compile $(curdir)/missing-macros/compile
$(curdir)/lz4/compile := $(curdir)/meson/compile
$(curdir)/lzma-old/compile := $(curdir)/zlib/compile
$(curdir)/lzop/compile := $(curdir)/cmake/compile $(curdir)/liblzo/compile
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
index b4f3ecc36b..1187191478 100644
--- a/tools/libtool/Makefile
+++ b/tools/libtool/Makefile
@@ -18,17 +18,31 @@ HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+export GNULIB_SRCDIR:=$(HOST_GNULIB_SRCDIR)
+
HOST_CONFIGURE_VARS += \
lt_cv_sys_dlsearch_path=""
+define Host/Bootstrap
+ ( \
+ cd $(HOST_BUILD_DIR); \
+ $(AM_TOOL_PATHS) \
+ ./bootstrap \
+ --force \
+ --skip-git \
+ --skip-po \
+ --gnulib-srcdir=$(GNULIB_SRCDIR) \
+ )
+endef
+
define Host/Prepare
$(call Host/Prepare/Default)
$(call Host/Uninstall)
- $(if $(QUILT),,(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
+ $(if $(QUILT),,$(call Host/Bootstrap))
endef
define Host/Configure
- $(if $(QUILT),(cd $(HOST_BUILD_DIR); touch README-release; $(AM_TOOL_PATHS) ./bootstrap --skip-git --skip-po --force))
+ $(if $(QUILT),$(call Host/Bootstrap))
$(call Host/Configure/Default)
endef