summaryrefslogtreecommitdiff
path: root/tools
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2023-04-09 11:26:20 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-11 17:30:32 +0200
commitcd8c698f78980356d8fd2408e54f0c1c1d04c349 (patch)
treecd2efb4ff59bdc9684bb50eb5dd41e1891c664c9 /tools
parentfea4ffdef28ffdb13b5a4e94506a976cb6271649 (diff)
downloadopenwrt-cd8c698f78980356d8fd2408e54f0c1c1d04c349.tar.gz
tools/mkimage: update to 2023.04
Update to latest version. Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'tools')
-rw-r--r--tools/mkimage/Makefile4
-rw-r--r--tools/mkimage/patches/030-allow-to-use-different-magic.patch8
2 files changed, 6 insertions, 6 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 022ac21974..a6d54f5eff 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,14 +7,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2023.01
+PKG_VERSION:=2023.04
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
https://mirror.cyberbits.eu/u-boot \
https://ftp.denx.de/pub/u-boot \
ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=69423bad380f89a0916636e89e6dcbd2e4512d584308d922d1039d1e4331950f
+PKG_HASH:=e31cac91545ff41b71cec5d8c22afd695645cd6e2a442ccdacacd60534069341
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
diff --git a/tools/mkimage/patches/030-allow-to-use-different-magic.patch b/tools/mkimage/patches/030-allow-to-use-different-magic.patch
index d88f1cf949..c33b0f4327 100644
--- a/tools/mkimage/patches/030-allow-to-use-different-magic.patch
+++ b/tools/mkimage/patches/030-allow-to-use-different-magic.patch
@@ -33,7 +33,7 @@ This patch makes it possible to set a custom image magic.
static const struct option longopts[] = {
{ "load-address", required_argument, NULL, 'a' },
-@@ -298,6 +300,14 @@ static void process_args(int argc, char
+@@ -302,6 +304,14 @@ static void process_args(int argc, char
case 'l':
params.lflag = 1;
break;
@@ -50,7 +50,7 @@ This patch makes it possible to set a custom image magic.
break;
--- a/tools/default_image.c
+++ b/tools/default_image.c
-@@ -56,7 +56,7 @@ static int image_verify_header(unsigned
+@@ -63,7 +63,7 @@ static int image_verify_header(unsigned
*/
memcpy(hdr, ptr, sizeof(struct legacy_img_hdr));
@@ -59,7 +59,7 @@ This patch makes it possible to set a custom image magic.
debug("%s: Bad Magic Number: \"%s\" is no valid image\n",
params->cmdname, params->imagefile);
return -FDT_ERR_BADMAGIC;
-@@ -119,7 +119,7 @@ static void image_set_header(void *ptr,
+@@ -142,7 +142,7 @@ static void image_set_header(void *ptr,
}
/* Build new header */
@@ -70,7 +70,7 @@ This patch makes it possible to set a custom image magic.
image_set_load(hdr, addr);
--- a/tools/imagetool.h
+++ b/tools/imagetool.h
-@@ -59,6 +59,7 @@ struct image_tool_params {
+@@ -67,6 +67,7 @@ struct image_tool_params {
int arch;
int type;
int comp;