summaryrefslogtreecommitdiff
path: root/package/utils/e2fsprogs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/e2fsprogs/Makefile')
-rw-r--r--package/utils/e2fsprogs/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/utils/e2fsprogs/Makefile b/package/utils/e2fsprogs/Makefile
index 9437947ab6..42c2971529 100644
--- a/package/utils/e2fsprogs/Makefile
+++ b/package/utils/e2fsprogs/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=e2fsprogs
PKG_VERSION:=1.47.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/tytso/e2fsprogs/v$(PKG_VERSION)/
@@ -156,6 +156,10 @@ CONFIGURE_ARGS += \
--disable-rpath \
--disable-fuse2fs
+ifneq ($(CONFIG_USE_MUSL),)
+ CONFIGURE_VARS += ac_cv_func_lseek64=yes
+endif
+
define Build/Prepare
$(call Build/Prepare/Default)
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/config/