summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-07-15 01:13:58 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-07-15 01:13:58 +0100
commitb41f76b5a070661aba9e558524ab22f23e387d74 (patch)
treecc030639b18f490a65aabf268e2983b3953b6c44
parent8d5208f044ba9c8cd871f8cea9719fc699604a49 (diff)
downloadprocd-b41f76b5a070661aba9e558524ab22f23e387d74.tar.gz
procd: fix compile if procd-ujail is not selected
Generating syscall-names.h was added as a dependency for ujail in order to support seccomp for OCI containers. This, however, slipped into the wrong place and broke cmake in case of procd-seccomp being selected but procd-ujail not being selected. Move dependency to the right place to fix that. Fixes: bb4a446 ("uxc: add container management CLI tool") Reported-by: Paul Blazejowski <paulb@blazebox.homeip.net> Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b149a06..1f77662 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,6 +114,9 @@ INSTALL(TARGETS ujail
RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
)
ADD_DEPENDENCIES(ujail capabilities-names-h)
+IF(SECCOMP_SUPPORT)
+ ADD_DEPENDENCIES(ujail syscall-names-h)
+ENDIF()
ADD_EXECUTABLE(ujail-console jail/console.c)
TARGET_LINK_LIBRARIES(ujail-console ${ubox} ${ubus} ${blobmsg_json})
@@ -127,9 +130,6 @@ INSTALL(TARGETS uxc
RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
)
endif()
-IF(SECCOMP_SUPPORT)
- ADD_DEPENDENCIES(ujail syscall-names-h)
-ENDIF()
IF(UTRACE_SUPPORT)
ADD_EXECUTABLE(utrace trace/trace.c)