summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-04 12:46:28 +0100
committerJohn Crispin <blogic@openwrt.org>2014-06-05 11:45:15 +0100
commit0467aebb79f64d1c9d05a84367fda7c02c4ea6b8 (patch)
tree4bc7eacbd8a5bdc324c5e34a97386810975eacc8 /CMakeLists.txt
parent54829607535631a6701a16113c95a0c09cbd45d8 (diff)
downloadprocd-0467aebb79f64d1c9d05a84367fda7c02c4ea6b8.tar.gz
allow instances to register ubus object that should be watched
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c50b05d..ace2b51 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ IF(APPLE)
ENDIF()
SET(SOURCES procd.c signal.c watchdog.c state.c inittab.c rcS.c ubus.c system.c
- service/service.c service/instance.c service/validate.c service/trigger.c
+ service/service.c service/instance.c service/validate.c service/trigger.c service/watch.c
plug/coldplug.c plug/hotplug.c utils/utils.c)
find_library(json NAMES json-c json)
@@ -42,6 +42,13 @@ INSTALL(TARGETS udevtrigger
)
+ADD_EXECUTABLE(upgraded upgraded.c watchdog.c)
+TARGET_LINK_LIBRARIES(upgraded ubox)
+INSTALL(TARGETS upgraded
+ RUNTIME DESTINATION sbin
+)
+
+
ADD_EXECUTABLE(askfirst utils/askfirst.c)
INSTALL(TARGETS askfirst
RUNTIME DESTINATION sbin