summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-06 17:46:04 +0100
committerJohn Crispin <blogic@openwrt.org>2015-03-06 17:46:23 +0100
commit47d5be7160e33966f5ded484232d10dcc220f172 (patch)
tree0909757acc977952f23a77345eafe2060e273cf2 /CMakeLists.txt
parentb6777a45becef915d6a99f01e044ad508bb278c6 (diff)
downloadprocd-47d5be7160e33966f5ded484232d10dcc220f172.tar.gz
json 0.12 fixes
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5414677..98395f5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,8 +14,7 @@ SET(SOURCES procd.c signal.c watchdog.c state.c inittab.c rcS.c ubus.c system.c
service/service.c service/instance.c service/validate.c service/trigger.c service/watch.c
plug/coldplug.c plug/hotplug.c utils/utils.c)
-find_library(json NAMES json-c json)
-SET(LIBS ubox ubus ${json} blobmsg_json json_script)
+SET(LIBS ubox ubus json-c blobmsg_json json_script)
IF(DEBUG)
ADD_DEFINITIONS(-DDEBUG -g3)