summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2021-10-11 23:04:38 +0100
committerDaniel Golle <daniel@makrotopia.org>2021-10-13 00:35:54 +0100
commitc44ab7fa061fda06d1496b6273ac7151189fb7a9 (patch)
treedb914401fe599955549d2c75694ff656d50ba8e1 /CMakeLists.txt
parent324ebd0a3c983bd12b1b330e23293b9e1d64044f (diff)
downloadprocd-c44ab7fa061fda06d1496b6273ac7151189fb7a9.tar.gz
jail: netifd: generate netifd uci config and mount it
Generate /etc/config/network by filtering the host config for uci sections which are marked for that specific jail. Feed that configuration to the per-container netifd instance. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d915af..d787052 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,7 @@ ENDIF()
FIND_LIBRARY(ubox NAMES ubox)
FIND_LIBRARY(ubus NAMES ubus)
+FIND_LIBRARY(uci NAMES uci)
FIND_LIBRARY(blobmsg_json NAMES blobmsg_json)
FIND_LIBRARY(json_script NAMES json_script)
FIND_LIBRARY(json NAMES json-c json)
@@ -113,7 +114,7 @@ ENDIF()
IF(JAIL_SUPPORT)
ADD_EXECUTABLE(ujail jail/jail.c jail/cgroups.c jail/cgroups-bpf.c jail/elf.c jail/fs.c jail/capabilities.c jail/netifd.c ${SOURCES_OCI_SECCOMP})
-TARGET_LINK_LIBRARIES(ujail ${ubox} ${ubus} ${blobmsg_json})
+TARGET_LINK_LIBRARIES(ujail ${ubox} ${ubus} ${uci} ${blobmsg_json})
INSTALL(TARGETS ujail
RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR}
)