summaryrefslogtreecommitdiff
path: root/upgraded
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-16 17:43:03 +0100
committerJohn Crispin <blogic@openwrt.org>2014-06-16 18:42:58 +0100
commit202318c6163657fc671b27527e5228cb8170af1d (patch)
tree3331a471a1760cdbabd80d5c7f2a93685d12e6c8 /upgraded
parent9c9c71a4e476be1e93f4d4c2c0527b5df0ff3c90 (diff)
downloadprocd-202318c6163657fc671b27527e5228cb8170af1d.tar.gz
move upgrade to its own subfolder
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'upgraded')
-rw-r--r--upgraded/CMakeLists.txt17
-rwxr-xr-xupgraded/upgradedbin0 -> 887098 bytes
-rw-r--r--upgraded/upgraded.c77
3 files changed, 94 insertions, 0 deletions
diff --git a/upgraded/CMakeLists.txt b/upgraded/CMakeLists.txt
new file mode 100644
index 0000000..7e08c0e
--- /dev/null
+++ b/upgraded/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(upgraded C)
+ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations)
+set(CMAKE_EXE_LINKER_FLAGS -static)
+set(CMAKE_FIND_LIBRARY_SUFFIXES .a)
+set(CMAKE_EXE_LINK_DYNAMIC_C_FLAGS)
+set(CMAKE_EXE_LINK_DYNAMIC_CXX_FLAGS)
+set(CMAKE_SHARED_LIBRARY_C_FLAGS)
+set(CMAKE_SHARED_LIBRARY_CXX_FLAGS)
+set(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS)
+set(CMAKE_SHARED_LIBRARY_LINK_CXX_FLAGS)
+ADD_EXECUTABLE(upgraded upgraded.c ../watchdog.c)
+TARGET_LINK_LIBRARIES(upgraded ubox rt)
+INSTALL(TARGETS upgraded
+ RUNTIME DESTINATION sbin
+)
diff --git a/upgraded/upgraded b/upgraded/upgraded
new file mode 100755
index 0000000..a78470c
--- /dev/null
+++ b/upgraded/upgraded
Binary files differ
diff --git a/upgraded/upgraded.c b/upgraded/upgraded.c
new file mode 100644
index 0000000..1e4057a
--- /dev/null
+++ b/upgraded/upgraded.c
@@ -0,0 +1,77 @@
+/*
+ * Copyright (C) 2013 Felix Fietkau <nbd@openwrt.org>
+ * Copyright (C) 2013 John Crispin <blogic@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU Lesser General Public License version 2.1
+ * as published by the Free Software Foundation
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ */
+
+#include <sys/reboot.h>
+
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <unistd.h>
+
+#include <libubox/uloop.h>
+
+#include "../watchdog.h"
+
+static struct uloop_process upgrade_proc;
+unsigned int debug = 2;
+
+static void upgrade_proc_cb(struct uloop_process *proc, int ret)
+{
+ if (ret)
+ fprintf(stderr, "sysupgrade aborted with return code: %d\n", ret);
+ uloop_end();
+}
+
+static void sysupgarde(char *folder)
+{
+ char *args[] = { "/sbin/sysupgrade", "nand", NULL, NULL };
+
+ args[2] = folder;
+ upgrade_proc.cb = upgrade_proc_cb;
+ upgrade_proc.pid = fork();
+ if (!upgrade_proc.pid) {
+ execvp(args[0], args);
+ fprintf(stderr, "Failed to fork sysupgrade\n");
+ exit(-1);
+ }
+ if (upgrade_proc.pid <= 0) {
+ fprintf(stderr, "Failed to start sysupgarde\n");
+ uloop_end();
+ }
+}
+
+int main(int argc, char **argv)
+{
+ pid_t p = getpid();
+
+ chdir("/tmp");
+
+ if (p != 1) {
+ fprintf(stderr, "this tool needs to run as pid 1\n");
+ return -1;
+ }
+ if (argc != 2) {
+ fprintf(stderr, "sysupgrade stage 2 failed, no folder specified\n");
+ return -1;
+ }
+
+ uloop_init();
+ watchdog_init(0);
+ sysupgarde(argv[1]);
+ uloop_run();
+
+ reboot(RB_AUTOBOOT);
+
+ return 0;
+}