summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2013-10-10 06:30:31 +0200
committerJo-Philipp Wich <jow@openwrt.org>2013-10-10 12:19:01 +0000
commita511e620c8d8c735e6a16b7f67382d587dcdaf31 (patch)
tree59de56ad2fae2afa5cbd2db89883e4f534b59775
parent095b1058c8cb1147d11028974be4067009bcfd67 (diff)
downloadrpcd-a511e620c8d8c735e6a16b7f67382d587dcdaf31.tar.gz
rpcd: CMake: fix out of tree builds
Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c0a4ef..4cef7d6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,8 @@ cmake_minimum_required(VERSION 2.6)
INCLUDE(CheckFunctionExists)
PROJECT(rpcd C)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations -Iinclude)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
+INCLUDE_DIRECTORIES(include)
OPTION(FILE_SUPPORT "File plugin support" ON)
OPTION(IWINFO_SUPPORT "libiwinfo plugin support" ON)