summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-01-26 15:29:09 +0100
committerJo-Philipp Wich <jow@openwrt.org>2013-01-26 15:29:09 +0100
commit0607cfda5b3449d0850861c140d36fbcc0f2ef1d (patch)
treedc61f7dd391ecd35644e28226f8b0d75166be576 /CMakeLists.txt
downloadrpcd-0607cfda5b3449d0850861c140d36fbcc0f2ef1d.tar.gz
initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..eef3856
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(luci-rpcd C)
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
+
+SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+
+IF(APPLE)
+ INCLUDE_DIRECTORIES(/opt/local/include)
+ LINK_DIRECTORIES(/opt/local/lib)
+ENDIF()
+
+ADD_EXECUTABLE(luci-rpcd main.c session.c file.c)
+TARGET_LINK_LIBRARIES(luci-rpcd ubox ubus)
+
+SET(CMAKE_INSTALL_PREFIX /usr)
+
+INSTALL(TARGETS luci-rpcd
+ RUNTIME DESTINATION sbin
+)