summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-11-14 13:43:19 +0100
committerJohn Crispin <blogic@openwrt.org>2013-11-15 17:10:20 +0100
commit0ff5e8917bc3205d9887d5f714369a0072829edc (patch)
tree7db64f5b6f607c4dc7317d2f2f64f01c1f691237 /CMakeLists.txt
parent2fdd374f4214129d93f10b7001adece9239752a2 (diff)
downloadubox-0ff5e8917bc3205d9887d5f714369a0072829edc.tar.gz
add validation code
Signed-off-by: John Crispin <blogic@openwrt.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54434d1..8cfbbc8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,3 +59,14 @@ TARGET_LINK_LIBRARIES(lsbloader ${LIBS})
INSTALL(TARGETS lsbloader
RUNTIME DESTINATION sbin
)
+
+ADD_LIBRARY(validate SHARED validate/validate.c)
+INSTALL(TARGETS validate
+ LIBRARY DESTINATION lib
+)
+
+ADD_EXECUTABLE(validate_data validate/cli.c)
+TARGET_LINK_LIBRARIES(validate_data ${LIBS} validate)
+INSTALL(TARGETS validate_data
+ RUNTIME DESTINATION sbin
+)