summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2016-07-01 16:05:23 -0700
committerJohn Crispin <john@phrozen.org>2016-07-01 15:19:37 +0200
commit81c38e8cc3913afcdf5c6916db0376000086b57f (patch)
treeb93e27957f1e5e794f2698c95af45e1416061b34 /CMakeLists.txt
parentfdda69207d1509e0383e3da549f71666b194c40a (diff)
downloadubox-81c38e8cc3913afcdf5c6916db0376000086b57f.tar.gz
cmake: Find uci header file
Add a CMake FIND_PATH and INCLUDE_DIRECTORIES searching for uci.h. Some external toolchains which do not include standard locations would fail to find the header otherwise. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 73e8753..6cf0c93 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,6 +40,9 @@ INSTALL(TARGETS validate
LIBRARY DESTINATION lib
)
+FIND_PATH(uci_include_dir uci.h)
+INCLUDE_DIRECTORIES(${uci_include_dir})
+
ADD_EXECUTABLE(validate_data validate/cli.c)
TARGET_LINK_LIBRARIES(validate_data ubox uci validate)
INSTALL(TARGETS validate_data