summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-10-19 15:14:47 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-10-19 16:21:21 +0100
commit13a4438b4ebdf85d301999e0a615640ac4c9b0a8 (patch)
tree955f761a1ecece13c41b5620ea7fe7b4d7e5723d
parent13efd05c1bb611a3b30f53858fcd3a13589e08be (diff)
downloadubus-13a4438b4ebdf85d301999e0a615640ac4c9b0a8.tar.gz
ubus: move /var/run/ubus.sock to /var/run/ubus/ubus.sock
This makes it possible to run ubus as non-root. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c0f760..117f0a3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,7 +13,7 @@ OPTION(BUILD_LUA "build Lua plugin" ON)
OPTION(BUILD_EXAMPLES "build examples" ON)
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
-SET(UBUS_UNIX_SOCKET "/var/run/ubus.sock")
+SET(UBUS_UNIX_SOCKET "/var/run/ubus/ubus.sock")
SET(UBUS_MAX_MSGLEN 1048576)
ADD_DEFINITIONS( -DUBUS_UNIX_SOCKET="${UBUS_UNIX_SOCKET}")