summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-02-15 19:11:58 +0100
committerFelix Fietkau <nbd@nbd.name>2021-02-15 19:12:12 +0100
commit2537be01858710e714c329153760c64fe3f8a73e (patch)
tree5887daa1eac8c9bb3ca9beb86e468aa88cabdfb0
parentd1d9ddf98d39b0bdc055060fb962335439445690 (diff)
downloadubus-2537be01858710e714c329153760c64fe3f8a73e.tar.gz
cmake: add a possibility to set library version
Add a new `ABIVERSION` define which allows to control the SOVERSION used for the built shared library. This is needed for downstream packaging to properly track breaking ABI changes when updating to newer versions of the library. Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 117f0a3..a65ccbb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,6 +68,10 @@ IF(UNIT_TESTING)
ADD_UNIT_TEST_SAN(ubusd_main ubusd-san)
ENDIF()
+IF(ABIVERSION)
+ SET_TARGET_PROPERTIES(ubus PROPERTIES VERSION ${ABIVERSION})
+ENDIF()
+
INSTALL(TARGETS ubus cli
ARCHIVE DESTINATION lib
LIBRARY DESTINATION lib