summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-26 21:55:03 +0100
committerFelix Fietkau <nbd@openwrt.org>2011-03-26 21:55:11 +0100
commit0e8c97eef4aa154543c539b13b5e16859cec8a25 (patch)
treec653aafd7d436f1d6d2f0ccd3d07f9f284f336b0 /CMakeLists.txt
parentdf707fa4bae31ba419b5ef351811be07826926ec (diff)
downloaduci-0e8c97eef4aa154543c539b13b5e16859cec8a25.tar.gz
fix include path
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d7d735..9e50a5b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ PROJECT(uci C)
SET(CMAKE_INSTALL_PREFIX /usr)
-ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -DUCI_PREFIX="${CMAKE_INSTALL_PREFIX}")
+ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -I. -DUCI_PREFIX="${CMAKE_INSTALL_PREFIX}")
OPTION(UCI_PLUGIN_SUPPORT "plugin support" ON)
OPTION(UCI_DEBUG "debugging support" OFF)
@@ -37,7 +37,7 @@ TARGET_LINK_LIBRARIES(ucimap-example uci-static ucimap dl)
ADD_SUBDIRECTORY(lua)
INSTALL(FILES uci.h uci_config.h ucimap.h
- DESTINATION include/libubox
+ DESTINATION include
)
INSTALL(TARGETS uci-shared uci-static cli cli-static