summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1f5efce..d9c03db 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,9 @@ IF(APPLE)
LINK_DIRECTORIES(/opt/local/lib)
ENDIF()
+FIND_PATH(ubox_include_dir libubox/ustream-ssl.h)
+INCLUDE_DIRECTORIES(${ubox_include_dir})
+
ADD_LIBRARY(uclient SHARED uclient.c uclient-http.c uclient-utils.c)
TARGET_LINK_LIBRARIES(uclient ubox dl)