summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-05-28 00:52:24 +0000
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-05-28 00:52:24 +0000
commit4e8baff3b76ee5ff24da13a8e7cf2d220c2aa35d (patch)
tree2ce9e371fcd1f59ca5c6c2d8a296c9a42048821b /Makefile
parent9f8cff6fab8c49d4a6c094e00e71212ebbd39601 (diff)
downloaduhttpd-4e8baff3b76ee5ff24da13a8e7cf2d220c2aa35d.tar.gz
[package] uhttpd:
- rewrite large parts of the server, use uloop event driven structure - support concurrent requests and make the upper limit configurable - implement initial version of HTTP-to-ubus JSON proxy and session.* namespace - add compile time support for debug information - code style changes - bump package revision git-svn-id: svn://svn.openwrt.org/openwrt/trunk/package/uhttpd/src@31931 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 2b08ec6..98226ed 100644
--- a/Makefile
+++ b/Makefile
@@ -41,6 +41,10 @@ ifeq ($(LUA_SUPPORT),1)
CFLAGS += -DHAVE_LUA
endif
+ifeq ($(UBUS_SUPPORT),1)
+ CFLAGS += -DHAVE_UBUS
+endif
+
world: compile
@@ -66,10 +70,19 @@ ifeq ($(TLS_SUPPORT),1)
-o $(TLSLIB) uhttpd-tls.c
endif
+ifeq ($(UBUS_SUPPORT),1)
+ UBUSLIB := uhttpd_ubus.so
+
+ $(UBUSLIB): uhttpd-ubus.c
+ $(CC) $(CFLAGS) $(LDFLAGS) $(FPIC) \
+ -shared -lubus -ljson -lblobmsg_json \
+ -o $(UBUSLIB) uhttpd-ubus.c
+endif
+
%.o: %.c
$(CC) $(CFLAGS) -c -o $@ $<
-compile: $(OBJ) $(TLSLIB) $(LUALIB)
+compile: $(OBJ) $(TLSLIB) $(LUALIB) $(UBUSLIB)
$(CC) -o uhttpd $(LDFLAGS) $(OBJ) $(LIB)
clean: