summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Palsson <karlp@etactica.com>2016-06-06 15:49:22 +0000
committerFelix Fietkau <nbd@nbd.name>2016-06-07 09:03:43 +0200
commit17085b7abc0cd09c64ccace6f8d16ddee5729678 (patch)
tree34df7cb84ee33c26846fc6c4aa482f4c6e97b0ea
parent6ba14990e63fc956e8aff3b0b09be1fd3aaa6d75 (diff)
downloadustream-ssl-17085b7abc0cd09c64ccace6f8d16ddee5729678.tar.gz
ustream-ssl: cyassl compatibility with build time options
Adds a HAVE_CYASSL definition to be consistent with polar/mbedtls. Uses that definition to include the wolfssl build time options. This enables the correct pullin of the "remainder" of the wolfssl openssl compatibility options, if they were enabled in the build of wolfssl in the first place. Signed-off-by: Karl Palsson <karlp@etactica.com>
-rw-r--r--CMakeLists.txt1
-rw-r--r--ustream-internal.h3
2 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1c2b32..2ce9bf8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,7 @@ ELSEIF(CYASSL)
IF (HAVE_CYASSL_VERSION_H)
ADD_DEFINITIONS(-DHAVE_CYASSL_VERSION_H)
ENDIF()
+ ADD_DEFINITIONS(-DHAVE_CYASSL)
SET(SSL_SRC ustream-io-cyassl.c ustream-openssl.c)
SET(SSL_LIB cyassl m)
ELSE()
diff --git a/ustream-internal.h b/ustream-internal.h
index 020e1c6..4932a0d 100644
--- a/ustream-internal.h
+++ b/ustream-internal.h
@@ -26,6 +26,9 @@
#elif defined(HAVE_POLARSSL)
#include "ustream-polarssl.h"
#else
+#if defined(HAVE_CYASSL)
+#include <wolfssl/options.h>
+#endif
#include "ustream-openssl.h"
#endif