summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcus Asteborg <maastebo@microsoft.com>2019-04-11 09:50:14 -0700
committerJean-Marc Valin <jmvalin@jmvalin.ca>2019-04-11 23:07:34 -0400
commit1f92613e7d01958d2ec1b0072c27c6f2c118fc01 (patch)
tree275fb827d60549974265bd4eb27f99a6a0da34ac /CMakeLists.txt
parent268780fbf07e95e31b3d443004b5c3a997f9cad3 (diff)
downloadopus-1f92613e7d01958d2ec1b0072c27c6f2c118fc01.tar.gz
CMake changes
If CMAKE_BUILD_TYPE is empty and CFlags are set then only use CFlags. If None are set then use CMAKE_BUILD_TYPE by Release by default. Signed-off-by: Jean-Marc Valin <jmvalin@jmvalin.ca>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e3115546..17ee3fc2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,5 @@
cmake_minimum_required(VERSION 3.1)
-include(opus_buildtype.cmake)
include(opus_functions.cmake)
get_library_version(OPUS_LIBRARY_VERSION OPUS_LIBRARY_VERSION_MAJOR)
@@ -17,6 +16,7 @@ string(REGEX
message(STATUS "Opus project version: ${PROJECT_VERSION}")
project(Opus LANGUAGES C VERSION ${PROJECT_VERSION})
+include(opus_buildtype.cmake)
option(OPUS_STACK_PROTECTOR "Use stack protection" ON)
option(OPUS_USE_ALLOCA "Use alloca for stack arrays (on non-C99 compilers)" OFF)