summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNathaniel R. Lewis <linux.robotdude@gmail.com>2019-05-08 21:51:22 -0700
committerJean-Marc Valin <jmvalin@jmvalin.ca>2020-01-19 15:51:04 -0500
commit60472f2dc2c89eed45de1a382eea5da4fb885db6 (patch)
tree9d5950e7577bcb971d18d0144155affab1ae02b5 /CMakeLists.txt
parent965a72e4c00aae7aa7fb634037585d60df61ba14 (diff)
downloadopus-60472f2dc2c89eed45de1a382eea5da4fb885db6.tar.gz
CMake: Add alias Opus::opus for opus library. Useful for CMake superbuild pattern.
Signed-off-by: Jean-Marc Valin <jmvalin@jmvalin.ca>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb516213..5c9df248 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -165,6 +165,8 @@ feature_summary(WHAT ALL)
add_library(opus ${opus_sources} ${opus_sources_float})
+add_library(Opus::opus ALIAS opus)
+
set(Opus_PUBLIC_HEADER
${CMAKE_CURRENT_SOURCE_DIR}/include/opus.h
${CMAKE_CURRENT_SOURCE_DIR}/include/opus_custom.h