summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRalph Giles <giles@mozilla.com>2011-09-06 23:18:00 -0700
committerRalph Giles <giles@mozilla.com>2011-09-07 11:06:23 -0700
commit35d4fb78eafc6aa738919a8c4984744e1bcf52d9 (patch)
tree2e4eda352abb98434356c9ddedb4bcc10a830894 /Makefile.am
parentee931fcd25f9d715e35d033cd96eedd90ed45e39 (diff)
downloadopus-35d4fb78eafc6aa738919a8c4984744e1bcf52d9.tar.gz
Add initial Doxygen support for generating api documentation.
Doxygen is a tool for generating programming documentation based on comments in header and source files. This commit adds the necessary configuration file and associated support in the autotools build. Right now it doesn't generate much documentation because our public header files aren't marked up. Warnings are printed for undocumented members and arguments.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 74f06880..612498ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ AUTOMAKE_OPTIONS = subdir-objects
lib_LTLIBRARIES = libopus.la
-SUBDIRS = . libcelt/tests
+SUBDIRS = . libcelt/tests doc
INCLUDES = -I$(top_srcdir)/libcelt -I$(top_srcdir)/silk -I$(top_srcdir)/silk/float -I$(top_srcdir)/silk/fixed