summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJean-Marc Valin <jean-marc.valin@usherbrooke.ca>2011-08-02 08:13:42 -0400
committerJean-Marc Valin <jean-marc.valin@usherbrooke.ca>2011-08-02 08:13:42 -0400
commitb2c00d2751f32aa9869250b65f6a7e4aa40a0116 (patch)
tree1e152d8abd832e546af1c2285066d87555c04b74 /Makefile.am
parent06d57b2165a3de0b8d1dd537382a80114b89081b (diff)
downloadopus-b2c00d2751f32aa9869250b65f6a7e4aa40a0116.tar.gz
Makefile fixes
silk_sources.mk no longer needs to be patched (s/if/ifdef/) for the draft Makefile to work.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7df07c82..76490f7f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,12 @@ include celt_sources.mk
include silk_sources.mk
include opus_sources.mk
+if FIXED_POINT
+SILK_SOURCES += $(SILK_SOURCES_FIXED)
+else
+SILK_SOURCES += $(SILK_SOURCES_FLOAT)
+endif
+
include celt_headers.txt
include silk_headers.txt
include opus_headers.txt