summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTristan Matthews <tmatth@videolan.org>2014-10-12 15:12:52 -0400
committerTristan Matthews <tmatth@videolan.org>2014-10-12 15:12:52 -0400
commitfd562eefa2f7b506d7bedd42335e97256c067d6e (patch)
treed07bebc7bd7331be4815141d26d515aa6ba62bdf /Makefile.am
parent32ff38bc8a3f1eba8cd27721cf4ce834ad12f9ad (diff)
downloadopus-fd562eefa2f7b506d7bedd42335e97256c067d6e.tar.gz
tests: fix linking for --enable-fixed-point on ARMv1.1.1-beta
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bcfeb20b..e20f7b41 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -106,12 +106,22 @@ celt_tests_test_unit_laplace_LDADD = $(LIBM)
celt_tests_test_unit_mathops_SOURCES = celt/tests/test_unit_mathops.c
celt_tests_test_unit_mathops_LDADD = $(LIBM)
+if CPU_ARM
+if OPUS_ARM_EXTERNAL_ASM
+celt_tests_test_unit_mathops_LDADD += libopus.la
+endif
+endif
celt_tests_test_unit_mdct_SOURCES = celt/tests/test_unit_mdct.c
celt_tests_test_unit_mdct_LDADD = $(LIBM)
celt_tests_test_unit_rotation_SOURCES = celt/tests/test_unit_rotation.c
celt_tests_test_unit_rotation_LDADD = $(LIBM)
+if CPU_ARM
+if OPUS_ARM_EXTERNAL_ASM
+celt_tests_test_unit_rotation_LDADD += libopus.la
+endif
+endif
celt_tests_test_unit_types_SOURCES = celt/tests/test_unit_types.c
celt_tests_test_unit_types_LDADD = $(LIBM)