summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-07-30 10:06:04 +0100
committerTim-Philipp Müller <tim@centricular.com>2018-07-30 10:12:14 +0100
commit39896fdfa8a2477d3171b28d7dfdd56254576073 (patch)
tree1e6620f72bb0e3726df78d8811ae597e2a8aacdf /meson.build
parent9d21f289e2e63da3d2bd7ee6877157df4b3babf2 (diff)
downloadorc-39896fdfa8a2477d3171b28d7dfdd56254576073.tar.gz
meson: rename 'disable_gtkdoc' option to 'gtk_doc' and make it an auto/feature option
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 9 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 87105b7..ee0a8e5 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project ('orc', 'c', version : '0.4.28.1',
- meson_version : '>= 0.46.0',
+ meson_version : '>= 0.47.0',
default_options : ['buildtype=debugoptimized',
'warning_level=1',
'c_std=gnu99'] )
@@ -133,8 +133,14 @@ if get_option('tests')
subdir('testsuite')
endif
-if not meson.is_cross_build() and not get_option('disable_gtkdoc') and host_os != 'windows'
- subdir('doc')
+if build_machine.system() == 'windows'
+ message('Disabling gtk-doc while building on Windows')
+else
+ if find_program('gtkdoc-scan', required : get_option('gtk_doc')).found()
+ subdir('doc')
+ else
+ message('Not building documentation as gtk-doc was not found')
+ endif
endif
pc_conf.set('prefix', get_option('prefix'))