summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2020-07-21 10:20:03 +0100
committerTim-Philipp Müller <tim@centricular.com>2020-07-21 10:20:03 +0100
commit9321e6238338afbecc6e987a727450970f9403d8 (patch)
tree9a0c950622ddc3cb745927c8b2a61be43b0a84b2 /meson.build
parent6f8be44448ebcca18785fce6cbdc4cf9b1361d59 (diff)
downloadorc-9321e6238338afbecc6e987a727450970f9403d8.tar.gz
meson: use / instead of join_paths() for readability
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index eeb3f17..84af0a0 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project ('orc', 'c', version : '0.4.31',
- meson_version : '>= 0.47.0',
+ meson_version : '>= 0.49.0',
default_options : ['buildtype=debugoptimized',
'warning_level=1',
'c_std=gnu99'] )
@@ -192,13 +192,13 @@ endif
# FIXME: use pkg-config module
pc_conf.set('prefix', get_option('prefix'))
pc_conf.set('exec_prefix', get_option('prefix'))
-pc_conf.set('libdir', join_paths(get_option('prefix'), get_option('libdir')))
-pc_conf.set('includedir', join_paths(get_option('prefix'), 'include'))
+pc_conf.set('libdir', get_option('prefix') / get_option('libdir'))
+pc_conf.set('includedir', get_option('prefix') / 'include')
pc_conf.set('VERSION', meson.project_version())
pc_conf.set('ORC_MAJORMINOR', orc_api)
pc_conf.set('LIBM', libm.found() ? '-lm' : '')
-pkgconfigdir = join_paths (get_option('libdir'), 'pkgconfig')
+pkgconfigdir = get_option('libdir') / 'pkgconfig'
configure_file(input : 'orc.pc.in',
output : 'orc-' + orc_api + '.pc',
configuration : pc_conf,