summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 921c980..012e7a9 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,5 +1,5 @@
-orcbin_PROGRAMS = example1 mt19937ar
+orcbin_PROGRAMS = example1 example2 example3 mt19937ar
if ENABLE_BACKEND_MMX
orcbin_PROGRAMS += volscale
@@ -8,3 +8,17 @@ endif
AM_LDFLAGS = $(ORC_LIBS)
AM_CFLAGS = $(ORC_CFLAGS)
+
+example1_SOURCES = example1.c example1orc.c example1orc.h
+example2_SOURCES = example2.c example2orc.c example2orc.h
+example3_SOURCES = example3.c example3orc.c example3orc.h
+
+update:
+ $(top_builddir)/tools/orcc$(EXEEXT) --implementation -o example1orc.c example1orc.orc
+ $(top_builddir)/tools/orcc$(EXEEXT) --header -o example1orc.h example1orc.orc
+ $(top_builddir)/tools/orcc$(EXEEXT) --implementation -o example2orc.c example2orc.orc
+ $(top_builddir)/tools/orcc$(EXEEXT) --header -o example2orc.h example2orc.orc
+ $(top_builddir)/tools/orcc$(EXEEXT) --implementation -o example3orc.c example3orc.orc
+ $(top_builddir)/tools/orcc$(EXEEXT) --header -o example3orc.h example3orc.orc
+
+