summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-06-14 16:22:23 -0400
committerColin Walters <walters@verbum.org>2012-06-14 19:34:28 -0400
commit10bf223f0a71031b7e0749760f517155f852cb6b (patch)
tree3b08384a4f3bb2289fc695c2b704e11c6672ffa2 /Makefile.am
parent78b0d9923822f627a93596bd413ae02a37c41e2d (diff)
downloadostree-10bf223f0a71031b7e0749760f517155f852cb6b.tar.gz
Support building with embedded libsoup
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am35
1 files changed, 24 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index af358779..7ff7d490 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@ AM_CPPFLAGS = -DDATADIR='"$(datadir)"' -DLIBEXECDIR='"$(libexecdir)"' \
-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_28 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_28
AM_CFLAGS = $(WARN_CFLAGS)
-if BUILD_EMBEDDED_GLIB
+if BUILD_EMBEDDED_DEPENDENCIES
SUBDIRS = embedded-dependencies .
else
SUBDIRS = .
@@ -40,22 +40,32 @@ noinst_PROGRAMS =
privlibdir = $(pkglibdir)
privlib_LTLIBRARIES =
-if BUILD_EMBEDDED_GLIB
+if BUILD_EMBEDDED_DEPENDENCIES
OT_INTERNAL_GIO_UNIX_CFLAGS = \
- -I$(top_builddir)/embedded-dependencies/install-glib/EMBEDGLIB/include/glib-2.0 \
- -I$(top_builddir)/embedded-dependencies/install-glib/EMBEDGLIB/include/gio-unix-2.0 \
- -I$(top_builddir)/embedded-dependencies/install-glib/EMBEDGLIB/lib/glib-2.0/include \
+ -I$(top_builddir)/embedded-dependencies/EMBEDDEPS/include/glib-2.0 \
+ -I$(top_builddir)/embedded-dependencies/EMBEDDEPS/include/gio-unix-2.0 \
+ -I$(top_builddir)/embedded-dependencies/EMBEDDEPS/lib/glib-2.0/include \
$(NULL)
OT_INTERNAL_GIO_UNIX_LIBS = \
- $(top_builddir)/embedded-dependencies/install-glib/EMBEDGLIB/lib/libglib-2.0.so \
- $(top_builddir)/embedded-dependencies/install-glib/EMBEDGLIB/lib/libgthread-2.0.so \
- $(top_builddir)/embedded-dependencies/install-glib/EMBEDGLIB/lib/libgmodule-2.0.so \
- $(top_builddir)/embedded-dependencies/install-glib/EMBEDGLIB/lib/libgobject-2.0.so \
- $(top_builddir)/embedded-dependencies/install-glib/EMBEDGLIB/lib/libgio-2.0.so \
+ $(top_builddir)/embedded-dependencies/EMBEDDEPS/lib/libglib-2.0.so \
+ $(top_builddir)/embedded-dependencies/EMBEDDEPS/lib/libgthread-2.0.so \
+ $(top_builddir)/embedded-dependencies/EMBEDDEPS/lib/libgmodule-2.0.so \
+ $(top_builddir)/embedded-dependencies/EMBEDDEPS/lib/libgobject-2.0.so \
+ $(top_builddir)/embedded-dependencies/EMBEDDEPS/lib/libgio-2.0.so \
+ $(NULL)
+OT_INTERNAL_SOUP_CFLAGS = \
+ $(OT_INTERNAL_GIO_UNIX_CFLAGS) \
+ -I$(top_builddir)/embedded-dependencies/EMBEDDEPS/include/libsoup-2.4 \
+ $(NULL)
+OT_INTERNAL_SOUP_LIBS = \
+ $(OT_INTERNAL_GIO_UNIX_LIBS) \
+ $(top_builddir)/embedded-dependencies/EMBEDDEPS/lib/libsoup-2.4.so \
$(NULL)
else
OT_INTERNAL_GIO_UNIX_CFLAGS = $(OT_DEP_GIO_UNIX_CFLAGS)
OT_INTERNAL_GIO_UNIX_LIBS = $(OT_DEP_GIO_UNIX_LIBS)
+OT_INTERNAL_SOUP_CFLAGS = $(OT_DEP_SOUP_CFLAGS)
+OT_INTERNAL_SOUP_LIBS = $(OT_DEP_SOUP_LIBS)
endif
include Makefile-daemon.am
@@ -108,8 +118,11 @@ endif
release-tag:
git tag -m "Release $(VERSION)" v$(VERSION)
+embed_dependency=tar --append --exclude='.git/*' --transform='s,^embedded-dependencies/,ostree-embeddeps-$(VERSION)/embedded-dependencies/,' --file=ostree-embeddeps-$(VERSION).tar.tmp
+
release-tarball-embedded:
git archive --format=tar --prefix=ostree-embeddeps-$(VERSION)/ HEAD > ostree-embeddeps-$(VERSION).tar.tmp
- tar --append --exclude='.git/*' --transform='s,^embedded-dependencies/,ostree-embeddeps-$(VERSION)/embedded-dependencies/,' --file=ostree-embeddeps-$(VERSION).tar.tmp embedded-dependencies/glib
+ $(embed_dependency) embedded-dependencies/glib
+ $(embed_dependency) embedded-dependencies/libsoup
mv ostree-embeddeps-$(VERSION).tar{.tmp,}
gzip -f ostree-embeddeps-$(VERSION).tar