summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2013-07-07 14:37:59 -0400
committerColin Walters <walters@verbum.org>2013-07-07 14:37:59 -0400
commit26cef497a6bda37f8fdbe98238985f5b99e0a80a (patch)
tree511e1083111d877be45ec4eace89a2e9b5756fda /Makefile.am
parentf6bca20551c994025e33972e29100ac0944cb82c (diff)
downloadostree-26cef497a6bda37f8fdbe98238985f5b99e0a80a.tar.gz
Remove built in "triggers"
Originally, the idea was that clients would replicate "OS/tree"s from a build server, but we'd run things like "ldconfig" on the client. This was to allow adding e.g. the nVidia binary driver. However, the triggers were the only thing in the system at the moment that really had expected knowledge of the *contents* of the OS, like the location of binaries. For now, it's architecturally cleaner if we move the burden of triggers to the tree builder (e.g. gnome-ostree or RPM). Eventually we may want OSTree to assist with this type of thing (perhaps something like RPM %ghost), but this is the right thing to do now.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 0 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 2f1a7935..ac4bf5ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -76,16 +76,13 @@ endif
libgsystem_srcpath := src/libgsystem
libgsystem_cflags = $(OT_INTERNAL_GIO_UNIX_CFLAGS) -I$(srcdir)/src/libgsystem
libgsystem_libs = $(OT_INTERNAL_GIO_UNIX_LIBS)
-if !TRIGGERS_ONLY
include src/libgsystem/Makefile-libgsystem.am
noinst_LTLIBRARIES += libgsystem.la
-endif
include Makefile-daemon.am
include Makefile-otutil.am
include Makefile-libostree.am
include Makefile-ostree.am
include Makefile-switchroot.am
-include Makefile-triggers.am
include Makefile-tests.am
include Makefile-dracut.am