summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2016-05-06 12:25:27 -0400
committerColin Walters (automation) <walters+githubbot@verbum.org>2016-05-06 16:49:35 +0000
commit49322a3f53fa2e4b98663963d6b4cc030f32e484 (patch)
tree8b568d8ef3b7d35adb660db9b1070902ba58aa43 /Makefile.am
parentdfbb61270a144dc1aae049b6d1c43927e4a0f4d4 (diff)
downloadostree-49322a3f53fa2e4b98663963d6b4cc030f32e484.tar.gz
build: Use --std=gnu99
It's actually very nice to be able to declare loop variables inside the initializer. Ideally we could turn off nested functions though. Closes: #284 Approved by: jlebon
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e49b7c59..cf67c4ba 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,7 +27,7 @@ AM_CPPFLAGS += -DDATADIR='"$(datadir)"' -DLIBEXECDIR='"$(libexecdir)"' \
-DG_LOG_DOMAIN=\"OSTree\" \
-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_40 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_40 \
-DSOUP_VERSION_MIN_REQUIRED=SOUP_VERSION_2_40 -DSOUP_VERSION_MAX_ALLOWED=SOUP_VERSION_2_48
-AM_CFLAGS += $(WARN_CFLAGS)
+AM_CFLAGS += -std=gnu99 $(WARN_CFLAGS)
DISTCHECK_CONFIGURE_FLAGS += --enable-gtk-doc --disable-maintainer-mode
GITIGNOREFILES = aclocal.m4 build-aux/ buildutil/*.m4 config.h.in gtk-doc.make