summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPhilip Withnall <withnall@endlessm.com>2017-05-07 20:57:53 +0100
committerAtomic Bot <atomic-devel@projectatomic.io>2017-05-08 18:48:07 +0000
commit50f73cbac35be97fd5895531e295d05dabaa8ed9 (patch)
tree9db6a07b4355b3d9449a4aa3705eaaea0b013154 /Makefile.am
parent6eac575f21b40310f7d661c0e99fa57dfbe513e5 (diff)
downloadostree-50f73cbac35be97fd5895531e295d05dabaa8ed9.tar.gz
build: Add -C arguments to some git invocations
This moves the build system a little closer towards being safe for builddir ≠ srcdir. Signed-off-by: Philip Withnall <withnall@endlessm.com> Closes: #832 Approved by: cgwalters
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 78cd6653..be505522 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@ include Makefile-decls.am
shortened_sysconfdir = $$(echo "$(sysconfdir)" | sed -e 's|^$(prefix)||' -e 's|^/||')
-OSTREE_GITREV=$(shell if command -v git >/dev/null 2>&1 && test -d $(srcdir)/.git; then git describe --abbrev=42 --tags --always HEAD; fi)
+OSTREE_GITREV=$(shell if command -v git >/dev/null 2>&1 && test -d $(srcdir)/.git; then git -C $(srcdir) describe --abbrev=42 --tags --always HEAD; fi)
ACLOCAL_AMFLAGS = -I buildutil -I libglnx ${ACLOCAL_FLAGS}
AM_CPPFLAGS += -DDATADIR='"$(datadir)"' -DLIBEXECDIR='"$(libexecdir)"' \
@@ -113,11 +113,11 @@ include Makefile-boot.am
include Makefile-man.am
release-tag:
- git tag -m "Release $(VERSION)" v$(VERSION)
+ git -C $(srcdir) tag -m "Release $(VERSION)" v$(VERSION)
embed_dependency=tar -C $(srcdir) --append --exclude='.git/*' --transform="s,^embedded-dependencies/,ostree-embeddeps-$${GITVERSION}/embedded-dependencies/," --file=$${TARFILE_TMP}
-git_version_rpm = $$(git describe | sed -e 's,-,\.,g' -e 's,^v,,')
+git_version_rpm = $$(git -C $(srcdir) describe | sed -e 's,-,\.,g' -e 's,^v,,')
release-tarball-embedded:
set -x; \