summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-05-25 15:00:45 -0400
committerColin Walters <walters@verbum.org>2012-05-25 15:00:45 -0400
commit5a0af4413119e1dfa46d9838ae461c5d4afa48e1 (patch)
treed395b310bdbf424e8058bff6bf1bbb0159bf0da2 /Makefile.am
parent9c27f1de995c3e8e96377d98b8385ff8b5b1421f (diff)
downloadostree-5a0af4413119e1dfa46d9838ae461c5d4afa48e1.tar.gz
core: use GLIB_VERSION_MAX_ALLOWED=2.28
We want to build/run even on relatively old OSes, so that we can be used to bootstrap and maintain newer builds.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9d31e098..fba107fd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,8 @@
# Boston, MA 02111-1307, USA.
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-AM_CPPFLAGS = -DDATADIR='"$(datadir)"' -DLIBEXECDIR='"$(libexecdir)"'
+AM_CPPFLAGS = -DDATADIR='"$(datadir)"' -DLIBEXECDIR='"$(libexecdir)"' \
+ -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_28 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_28
AM_CFLAGS = $(WARN_CFLAGS)
NULL =