summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Lebon <jonathan@jlebon.com>2019-09-25 11:27:38 -0400
committerAtomic Bot <atomic-devel@projectatomic.io>2019-09-25 21:05:32 +0000
commit5ea85ba5ac9a33d014264e48784d59d81ea61b91 (patch)
tree7e58ab7d05df9a8cb02cea240f8de89063b6e860 /configure.ac
parentc6c640f3aefb4195432e77478f24bd4d842495e3 (diff)
downloadostree-5ea85ba5ac9a33d014264e48784d59d81ea61b91.tar.gz
configure.ac: Add more details on how to do a release
Closes: #1928 Approved by: cgwalters
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 807af38e..6861afb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,8 +1,11 @@
AC_PREREQ([2.63])
-dnl If doing a final release, remember to follow the instructions to
-dnl update libostree-released.sym from libostree-devel.sym, and update the checksum
-dnl in test-symbols.sh, and also set is_release_build=yes below. Then make
-dnl another post-release commit to bump the version, and set is_release_build=no.
+dnl To do a release: follow the instructions to update libostree-released.sym from
+dnl libostree-devel.sym, update the checksum in test-symbols.sh, set is_release_build=yes
+dnl below. Then make another post-release commit to bump the version and set
+dnl is_release_build=no.
+dnl Seed the release notes with `git-shortlog-with-prs <previous-release>..`. Then use
+dnl `git-evtag` to create the tag and push it. Finally, create a GitHub release and attach
+dnl the tarball from `make dist`.
m4_define([year_version], [2019])
m4_define([release_version], [5])
m4_define([package_version], [year_version.release_version])