summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2012-12-06 22:42:02 +0100
committerStef Walter <stefw@gnome.org>2013-01-09 13:49:44 +0100
commit3d503948450d69293a3fdfec096e398fedf714f2 (patch)
tree17b68364a71602b846c5122c8007b86fd51812c2 /Makefile.am
parentc343f355b6abfe65adc696b57b18dc57c834acbc (diff)
downloadp11-kit-3d503948450d69293a3fdfec096e398fedf714f2.tar.gz
Move debug and library code into the common/ subdirectory
Start using p11_ as our internal prefix rather than _p11_. We explicitly export p11_kit_ so this is fine as far as visibility. Move the threading, mutex, and module compat, dict, and array code into the common directory too. Take this opportunity to clean up a bit of internal API as well, since so many lines are being touched internally.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index ac00ffd..2e28212 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,13 @@
SUBDIRS = \
+ build \
+ common \
p11-kit \
tools \
- tests \
doc \
po
-ACLOCAL_AMFLAGS = -I m4
+ACLOCAL_AMFLAGS = -I build/m4
DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc \
@@ -28,12 +29,12 @@ dist-hook:
if WITH_COVERAGE
coverage:
- mkdir -p tests/coverage
+ mkdir -p build/coverage
$(LCOV) --directory . --zerocounters
$(MAKE) check
- $(LCOV) --directory . --capture --output-file tests/coverage.info
- $(GENHTML) --output-directory tests/coverage tests/coverage.info
- @echo "file://$(abs_top_builddir)/tests/coverage/index.html"
+ $(LCOV) --directory . --capture --output-file build/coverage.info
+ $(GENHTML) --output-directory build/coverage build/coverage.info
+ @echo "file://$(abs_top_builddir)/build/coverage/index.html"
endif
if ENABLE_GTK_DOC