summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-03-31 14:58:30 +0200
committerStef Walter <stefw@collabora.co.uk>2011-03-31 14:58:30 +0200
commit52dab5cd52b19352e9f29b16c686fc545d2aadf1 (patch)
treea6e731631f45e08754481176b6336f33ef81d756 /Makefile.am
parenta0ef9771b882bf2dc5bd56fcc6bcfdf47ed90feb (diff)
downloadp11-kit-52dab5cd52b19352e9f29b16c686fc545d2aadf1.tar.gz
Add make target for uploading docs.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 811b752..b5eccbb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,4 +31,10 @@ coverage:
@echo "file://$(abs_top_builddir)/tests/coverage/index.html"
endif
+if ENABLE_GTK_DOC
+upload-doc: all
+ rsync -Hvax --exclude doc \
+ doc/html/./ anarchy.freedesktop.org:/srv/p11-glue.freedesktop.org/www/doc/p11-kit/./
+endif
+
EXTRA_DIST = config.rpath