summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@thewalter.net>2014-08-15 08:41:43 +0200
committerStef Walter <stef@thewalter.net>2014-08-15 10:43:04 +0200
commit677dee1a04058aefe8c7689f88da52afe3b4b4bb (patch)
tree570bf0fb53fa659954f03e146696969ab97abe3a /Makefile.am
parent2a35a67923c26cd38839197aee51c274e5c2550e (diff)
downloadp11-kit-677dee1a04058aefe8c7689f88da52afe3b4b4bb.tar.gz
Move to non-recursive Makefile for building bins and libs
Still use recursive for documentation and translation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am66
1 files changed, 50 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index bef51cf..9032154 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,21 +1,44 @@
-include $(top_srcdir)/build/Makefile.decl
-
+NULL =
WEBHOST = anarchy.freedesktop.org
WEBBASE = /srv/p11-glue.freedesktop.org/www
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/common \
+ -DBINDIR=\"$(bindir)\" \
+ -DBUILDDIR=\"$(abs_builddir)\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DPRIVATEDIR=\"$(privatedir)\" \
+ -DSRCDIR=\"$(abs_srcdir)\" \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
+ -DP11_KIT_FUTURE_UNSTABLE_API
+
+bin_PROGRAMS =
+
+CHECK_PROGS =
+
+EXTRA_DIST = HACKING
+
+incdir = $(includedir)/p11-kit-1/p11-kit
+inc_HEADERS =
+
+lib_LTLIBRARIES =
+
+noinst_LTLIBRARIES =
+noinst_PROGRAMS = $(CHECK_PROGS)
+noinst_SCRIPTS =
+
+TESTS = $(CHECK_PROGS)
+
+include common/Makefile.am
+include p11-kit/Makefile.am
+
if WITH_TRUST_MODULE
-TRUST_DIR = trust
-else
-TRUST_DIR =
+include trust/Makefile.am
endif
-SUBDIRS = \
- common \
- p11-kit \
- $(TRUST_DIR) \
- doc \
- po
+SUBDIRS = . doc po
ACLOCAL_AMFLAGS = -I build/m4
@@ -25,6 +48,22 @@ DISTCHECK_CONFIGURE_FLAGS = \
--enable-strict \
CFLAGS='-O2'
+
+MEMCHECK_ENV = $(TEST_RUNNER) valgrind --error-exitcode=80 --quiet
+
+LEAKCHECK_ENV = $(TEST_RUNNER) valgrind --error-exitcode=81 --quiet --leak-check=yes
+
+HELLCHECK_ENV = $(TEST_RUNNER) valgrind --error-exitcode=82 --quiet --tool=helgrind
+
+memcheck: all
+ make $(AM_MAKEFLAGS) TESTS_ENVIRONMENT="$(MEMCHECK_ENV)" check-TESTS
+
+leakcheck: all
+ make $(AM_MAKEFLAGS) TESTS_ENVIRONMENT="$(LEAKCHECK_ENV)" check-TESTS
+
+hellcheck: all
+ make $(AM_MAKEFLAGS) TESTS_ENVIRONMENT="$(HELLCHECK_ENV)" check-TESTS
+
dist-hook:
@if test -d "$(srcdir)/.git"; \
then \
@@ -64,10 +103,5 @@ upload-release: $(DIST_ARCHIVES)
gpg --detach-sign --local-user 'stef@thewalter.net' $<
scp $< $<.sig $(WEBHOST):$(WEBBASE)/releases/
-EXTRA_DIST = \
- build/Makefile.tests \
- build/Makefile.decl \
- HACKING
-
transifex:
cd $(srcdir) && sh build/tx-update