summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2012-12-06 22:42:02 +0100
committerStef Walter <stefw@gnome.org>2013-01-09 13:49:44 +0100
commit3d503948450d69293a3fdfec096e398fedf714f2 (patch)
tree17b68364a71602b846c5122c8007b86fd51812c2 /common/Makefile.am
parentc343f355b6abfe65adc696b57b18dc57c834acbc (diff)
downloadp11-kit-3d503948450d69293a3fdfec096e398fedf714f2.tar.gz
Move debug and library code into the common/ subdirectory
Start using p11_ as our internal prefix rather than _p11_. We explicitly export p11_kit_ so this is fine as far as visibility. Move the threading, mutex, and module compat, dict, and array code into the common directory too. Take this opportunity to clean up a bit of internal API as well, since so many lines are being touched internally.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..f37a501
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,11 @@
+NULL =
+
+SUBDIRS = . tests
+
+EXTRA_DIST = \
+ array.c array.h \
+ compat.c compat.h \
+ debug.c debug.h \
+ dict.c dict.h \
+ library.c library.h \
+ $(NULL)