summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-01-02 16:52:02 +0100
committerStef Walter <stefw@gnome.org>2013-01-09 13:49:44 +0100
commit4a0bd25fcafae57ef2ae0cfe8676eee2332d5951 (patch)
tree09b8df1ef09b7aa1d2369f3a9aaada3b5612a80a /common/Makefile.am
parent8fb222266c5bf9181cd934c27528507d45476dad (diff)
downloadp11-kit-4a0bd25fcafae57ef2ae0cfe8676eee2332d5951.tar.gz
Move the pkcs11.h header files into common directory
* Allows use of them across the whole project * Put a stub file in the p11-kit/ directory, so we can still refer to the headers using that path, which is what it will be at when in the installed includes directory.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 754d7cd..c23e6d9 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -2,6 +2,12 @@ NULL =
SUBDIRS = . tests
+incdir = $(includedir)/p11-kit-1/p11-kit
+
+inc_HEADERS = \
+ pkcs11.h \
+ $(NULL)
+
noinst_LTLIBRARIES = \
libp11-compat.la \
libp11-library.la \
@@ -16,4 +22,5 @@ libp11_library_la_SOURCES = \
debug.c debug.h \
dict.c dict.h \
library.c library.h \
+ pkcs11.h pkcs11x.h \
$(NULL)