summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-01-24 11:28:47 +0100
committerStef Walter <stefw@gnome.org>2013-02-05 14:18:29 +0100
commit603c7d4eb996f51178ccc9d235597497bbb2c7a4 (patch)
tree738622a26134b4251b5d395bbe6725fb2c5844f2 /common/Makefile.am
parentf6db686846480e0611879c5f4751955a53859808 (diff)
downloadp11-kit-603c7d4eb996f51178ccc9d235597497bbb2c7a4.tar.gz
Add basic checksum algorithms
The SHA-1 and MD5 digests here are used for checksums in legacy protocols. We don't use them in cryptographic contexts at all. These particular algorithms would be poor choices for that.
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 972c703..aae9b35 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -26,6 +26,15 @@ libp11_library_la_SOURCES = \
dict.c dict.h \
library.c library.h \
pkcs11.h pkcs11x.h \
+ pkix.asn pkix.asn.h \
+ $(NULL)
+
+noinst_LTLIBRARIES += \
+ libp11-data.la \
+ $(NULL)
+
+libp11_data_la_SOURCES = \
+ checksum.c checksum.h \
$(NULL)
libp11_mock_la_SOURCES = \