summaryrefslogtreecommitdiff
path: root/common/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-04-02 20:40:53 +0200
committerStef Walter <stefw@gnome.org>2013-04-03 10:39:09 +0200
commitfcc3a83cc4d540bc2c4096524b5e8003046ba561 (patch)
tree5bc566d6813448f83269797ce05aadeb02cdf36f /common/Makefile.am
parentae7dd1be6d431f25b101bc7e2b3fa373a8cbb47b (diff)
downloadp11-kit-fcc3a83cc4d540bc2c4096524b5e8003046ba561.tar.gz
Separate library init from message code
Put library init/uninit code its into their own statically linked library so that they don't get linked into the p11-kit executable. Refactor the message code so that the library initialization can plug in its per thread message buffer. https://bugs.freedesktop.org/show_bug.cgi?id=63046
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index bfed1d7..cb6e95e 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -10,29 +10,30 @@ inc_HEADERS = \
$(NULL)
noinst_LTLIBRARIES = \
- libp11-compat.la \
+ libp11-common.la \
libp11-library.la \
libp11-mock.la \
$(NULL)
-libp11_compat_la_SOURCES = \
- compat.c compat.h \
- $(NULL)
-
-libp11_library_la_SOURCES = \
+libp11_common_la_SOURCES = \
attrs.c attrs.h \
array.c array.h \
buffer.c buffer.h \
+ compat.c compat.h \
constants.c constants.h \
debug.c debug.h \
dict.c dict.h \
hash.c hash.h \
lexer.c lexer.h \
- library.c library.h \
+ message.c message.h \
pkcs11.h pkcs11x.h \
url.c url.h \
$(NULL)
+libp11_library_la_SOURCES = \
+ library.c library.h \
+ $(NULL)
+
libp11_mock_la_SOURCES = \
mock.c mock.h \
$(NULL)