summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStef Walter <stef@thewalter.net>2013-07-10 15:22:00 +0200
committerStef Walter <stef@thewalter.net>2013-07-10 15:25:40 +0200
commitd00f6b24e5349d8d37868b8f4451b1dc9b38767e (patch)
tree5394ce5809dc3bf9d112f679eec1c179a4f9727d /configure.ac
parentfb039d0c292c3cd339179bdc98a09d4103fb9c5f (diff)
downloadp11-kit-d00f6b24e5349d8d37868b8f4451b1dc9b38767e.tar.gz
Build with -fno-common to catch definition problems
Fix some global variables not declared as extern https://bugs.freedesktop.org/show_bug.cgi?id=66015
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5eb6c2c..b0bbbd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -378,7 +378,7 @@ if test "$GCC" = "yes"; then
-Wmissing-prototypes -Wnested-externs -Wpointer-arith \
-Wdeclaration-after-statement -Wformat=2 -Winit-self \
-Waggregate-return -Wno-missing-format-attribute \
- -fno-strict-aliasing"
+ -fno-strict-aliasing -fno-common"
for option in -Wmissing-include-dirs -Wundef; do
SAVE_CFLAGS="$CFLAGS"