summaryrefslogtreecommitdiff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@thewalter.net>2013-07-17 11:58:05 +0200
committerStef Walter <stef@thewalter.net>2013-07-18 13:04:35 +0200
commit52a84b84a924a9f1cd8090b0a47b9f7d00ca69f3 (patch)
tree32428cc8b83eaa360b8b53e92f769cac1cf8a17e /doc/manual/Makefile.am
parent936e4c229a4ed205e9981fc4f31acea063701b69 (diff)
downloadp11-kit-52a84b84a924a9f1cd8090b0a47b9f7d00ca69f3.tar.gz
Support expanding $XDG_CONFIG_HOME in user config paths
If ~/.config is specified as a prefix to a configured path, then it is expanded to the $XDG_CONFIG_HOME if that exists Add --with-user-config ./configure option to configure a different user config directory. Interpolate the right directories into documentation.
Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
index ea6166e..ab73373 100644
--- a/doc/manual/Makefile.am
+++ b/doc/manual/Makefile.am
@@ -83,7 +83,11 @@ content_files=p11-kit-config.xml p11-kit-sharing.xml \
# SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
# These files must be listed here *and* in content_files
# e.g. expand_content_files=running.sgml
-expand_content_files=
+expand_content_files= \
+ version.xml \
+ userdir.xml \
+ sysdir.xml \
+ $(NULL)
# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
# Only needed if you are using gtkdoc-scangobj to dynamically query widget
@@ -98,6 +102,14 @@ p11-kit-sections.txt: $(srcdir)/p11-kit-sections.txt
p11-kit-overrides.txt: $(srcdir)/p11-kit-overrides.txt
cp $(srcdir)/p11-kit-overrides.txt p11-kit-overrides.txt
+# Generate our files with variables
+sysdir.xml:
+ echo -n $(p11_system_config) > "$@"
+userdir.xml:
+ echo -n $(p11_user_config) > "$@"
+version.xml:
+ echo -n $(VERSION) > "$@"
+
# This includes the standard gtk-doc make rules, copied by gtkdocize.
include $(top_srcdir)/gtk-doc.make
@@ -140,6 +152,7 @@ CLEANFILES += \
EXTRA_DIST += \
$(MAN_IN_FILES) \
- version.xml.in \
+ sysdir.xml \
+ userdir.xml \
version.xml \
$(NULL)